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1 Introducción 

 
El presente documento describe cuáles son las tareas que se pueden ejecutar en la explotación de la 

herramienta Badboy. 
 
El contenido del documento integra, tanto los aspectos de uso en el entorno de EJIE como las 

características principales de funcionamiento de la aplicación. 
 

2 Conceptos básicos 

 
Badboy es una herramienta de gran alcance diseñada para ayudar en la prueba y en el desarrollo de 

aplicaciones. Permite efectuar el testeo de la Web, con docenas de características incluyendo una interfaz 
simple, fácil e intuitiva, mediante los métodos de captura y repetición, siendo una gran ayuda para la prueba de 
carga de gran alcance, informes detallados, gráficos, etc. 

 
Badboy trae embebido el navegador Internet Explorer de Microsoft, monitorizando y controlando las 

acciones que se producen. 
 
Esto permite: 
 

 Realizar capturas de los parámetros del CGI, las páginas y los framesets peticionados. 
 

 Modificar dichas capturas y volver a ejecutarlas en cualquier momento automáticamente. 
 

 Grabar las capturas como scripts y compartirlos dentro del entorno de trabajo. 
 

 Recoger las estadísticas del funcionamiento mientras se ejecuta una prueba. 
 

 Realizar pruebas de regresión de áreas completas de sitios Web complejos con un solo clic. 
 
Badboy incluye una potente funcionalidad para permitir crear scripts, de una manera sencilla, con las 

navegaciones realizadas por sitios Web complejos sin la intervención del usuario. Una vez que estén creados 
los scripts, éstos se pueden compartir para conseguir un mayor aumento de la productividad. 

 
Se deberán tener en consideración los siguientes apartados: 
 

 JScript no puede exportarse: Debido a que JMeter no dispone de una ventana de navegación 
de Internet embebida, todos aquellos elementos que estén bajo JScript no se exportarán. 

 
 Las fuentes de datos no se exportan: JMeter tiene su propio concepto para sustituir fuentes de 

datos. Cuando se exporta un archivo, todas sus variables serán creadas en JMeter como 
"parámetros del usuario". Por lo que, si se desea, se puede proporcionar un archivo para JMeter 
para leer los valores de dichas variables. Para ver cómo se efectúa esta operación, en la ayuda 
de JMeter, en el apartado de "HTTP User Parameter Modifier" se explica con detalle como 
efectuar estas operaciones. 

 
 Los incrementos no se exportan: JMeter no utiliza incrementos para modificar variables. Las 

variables son modificadas automáticamente por la iteración de un bucle y la presencia de un 
parámetro del usuario. 
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 Las navegaciones no se exportan: Las navegaciones necesitan tener una ventana de 

navegador y no son soportadas directamente bajo JMeter. Pueden simularse con las propias 
características de JMeter. 

 
 Las aserciones no se exportan (se prevé que en futuras versiones del producto estén 

soportadas). 
 
Aún disponiendo de de una gran funcionalidad, el objetivo y prioridades de uso desde EJIE es el exportar 

las grabaciones Web efectuadas por Badboy, al lenguaje de scripting interpretado por JMeter. Como estas 
grabaciones son compatibles mediante el scripting con las pruebas bajo JMeter, será éste el uso principal y 
prioritario con el que Badboy será utilizado. 

 
Para obtener información adicional sobre el producto acceder a su página Web: 
 

http://www.badboy.com.au/ 
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3 Funciones elementales 

 
La herramienta permite realizar múltiples operaciones que se irán reflejando en posteriores apartados. El 

presente apartado se va a centrar principalmente en la creación de las diferentes navegaciones por los 
diferentes casos de uso de una aplicación para, a continuación, exportarlas a JMeter. 

 
Nota: El presente manual está orientado principalmente al uso de Badboy como herramienta de creación 

de navegaciones para su exportación a JMeter. 
 

3.1 Identificación de las diferentes áreas de trabajo 

 
Al acceder a Badboy, nos encontramos con la siguiente interfaz gráfica: 
 

 
 
El área de trabajo está dividida en diferentes secciones: 
 

 Sección de Menús y Accesos Rápidos: En esta sección se encuentran todas las acciones que 
es posible realizar por la herramienta. 
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 Sección de Script: Aquí se podrán ver las peticiones, las repuestas, los parámetros CGI y las 

distintas acciones que se hayan considerado durante la navegación. Se agrupan por: Carpeta, 
Prueba y Paso. 

 
 
 Sección de Resumen, Variables, Gráficos, Herramientas y Checks: Esta sección dispone de 

pestañas para poder visualizar los datos correspondientes a las diferentes acciones realizadas 
en el transcurso de la navegación. 

 

 
 
 Sección de Navegación: Aquí se verá el contenido de la Web y es la sección desde donde se 

ejecutarán las diferentes acciones para la grabación de las mismas bajo la herramienta. 
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3.2 Crear un nuevo proyecto de navegación 

 

Podremos crear un nuevo entorno de navegación pulsando el icono  existente en la sección de Menús, 
o bien a través del menú File > New: 

 

 
 
Una vez hemos creado el nuevo proyecto, introduciremos en el campo URL 
 

 
 
la dirección en donde tenemos la aplicación y sobre el cual se desea crear la grabación de la navegación. 
 

Una vez se haya introducido, pulsaremos sobre el botón , o bien pulsaremos la tecla Intro o Enter. 
 

3.3 Cómo grabar una navegación 

 

Siempre por defecto disponemos del botón de grabación  activado, por lo que desde el primer 
momento en el que se accede al aplicativo se está grabando la navegación. 
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Podemos observar que en la sección de Script, nos aparece uno, que se corresponde con el primer 

acceso al aplicativo. Si seguimos navegando por el aplicativo, se irán aumentando los elementos para un paso 
dado: 

 

 
 
A su vez, en la sección de Script, podemos ver los tipos de respuesta e incluso los valores existentes en 

cada ejecución: 
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Un paso no es más que un agrupador de navegaciones. Se pueden crear tantos pasos como se necesiten. 

Para ello, se pulsará sobre el icono . Pero también podemos agrupar los pasos en una nueva prueba, 

pulsando , e incluso una nueva carpeta de pruebas con : 

 
 
Una vez hemos terminado la navegación, procederemos a guardarla en disco, bien para poder ejecutarla 

en otra ocasión, modificarla o compartirla con otros miembros del equipo de proyecto. Para ello pulsaremos 

sobre el botón  o bien accederemos al menú desde donde ejecutaremos la acción de grabar. 
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Nos pedirá una ubicación y un nombre de archivo a la hora de salvar. 
 

3.4 Exportar una grabación a JMeter 

 
Una vez disponemos de una grabación de una navegación efectuada en el aplicativo Badboy, podremos 

proceder a exportarla a JMeter. 
Para ello, accederemos al menú File > Export to JMeter. 
 

 
 
Nos pedirá una ubicación y un nombre de archivo a la hora de salvar. 
 
Con ello se procederá a crear un archivo que es capaz de ser interpretado por la herramienta JMeter para 

su posterior procesado. 
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4 Funciones avanzadas 

 

4.1 Automatización de scripts 

 
Ser capaz de reproducir repetidamente una secuencia de actividades de navegación puede resultar un 

mecanismo muy útil para depurar y probar un sitio Web. 
 
Lamentablemente, repetir peticiones ya lanzadas anteriormente puede no satisfacer los requisitos de 

sitios Web complejos. Situaciones en los que esto puede ser así: 
 

 Un identificador introducido debe ser único. Introducir algunos valores dos veces genera un 
error. 

 
 Se ha grabado el script en un servidor (por ejemplo, la máquina de desarrollo local) pero se 

desea reproducirlo bajo uno diferente (se necesitará una manera de modificar el nombre de la 
máquina sobre la que lanzar las peticiones). 

 
Badboy permite resolver estos problemas de diferentes maneras: 
 

 Editar los parámetros. 
 Utilizar variables en los scripts. 
 Usar una gran variedad de herramientas tales como Buscar y Reemplazar. 

 

4.1.1. Editar parámetros y hosts 

 
Badboy permite editar los valores de los parámetros y los nombres de hosts en el script considerado. 
 
Simplemente hay que hacer doble “clic”: 
 

 En una petición  para editar el host o su path. 

 En el parámetro  al cual se desea cambiar su valor. 
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Ésta es la manera más simple de cambiar los valores necesarios antes de ejecutar el script. 
 

4.1.2. Buscar y Reemplazar 

 
Si se desea cambiar un valor varias veces a lo largo del script la característica Edit > Search/Replace 

facilita esta tarea. 
 

 
 

4.1.3. Variables 

 
Si se tienen valores que cambian con frecuencia puede resultar tedioso usar la opción Search/Replace. 

Para facilitar esta operación Badboy proporciona una característica denominada "script variables". 
 
Estas variables se muestran en la pestaña Variables de la sección correspondiente y contienen los 

valores de las variables que pueden ser referenciadas a través de su nombre en el script usando la notación 
 
${nombre de variable} 
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De esta manera se pueden crear scripts que incluyan un mismo lugar en múltiples lugares pero 

mantenidos en un único sitio. 
 

4.1.4. Variables con un valor único 

 
A veces, como ya se ha comentado, es necesario garantizar que una variable tenga un valor único cada 

vez que se ejecuta el script. Para ello Badboy incluye el elemento Increment, al que se puede acceder a través 
de la pestaña Herramientas, que proporciona múltiples posibilidades a la hora de asignar valores únicos a las 
variables. 
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4.2 Resultados 

 
Tras lanzar un script es importante mantener un registro de lo ocurrido. Por ejemplo, es interesante 

conocer el tiempo medio transcurrido entre petición y respuesta, etc. Badboy captura toda esta información y 
hace posible acceder a ella de manera rápida a través de la vista Resumen. 

 

 
 
La siguiente tabla describe los datos aportados en esta vista Resumen: 
 

Estadística Descripción 
  
Played El número de elementos del script que fueron ejecutados y devolvieron 

una respuesta. 
  
Succeeded El número de elementos del script que fueron ejecutados y devolvieron 

una respuesta exitosa. 
  
Failed El número de elementos del script que fueron ejecutados y devolvieron 

una respuesta fallida. 
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Avg Time (ms) El porcentaje de tiempo (en milisegundos) para los elementos que 

fueron ejecutaron y que devolvieron una respuesta. 
  
Assertions El número de aserciones fallidas. 
  
Warnigs El número de Warnings generados.  
  
Timeouts El número de desconexiones que se han producido. 
  
Max Time (ms) El mayor tiempo transcurrido en una única repuesta. 

 
 

4.3 Generar Informes 

 
Ya se ha visto que la pestaña Resumen muestra la información aportada tras la ejecución del script. 
 
Sin embargo, si se desea obtener una visión más detallada de los resultados obtenidos y además sin la 

necesidad de tener que estar ejecutando Badboy y con la posibilidad de integrar estos resultados con 
programas externos o documentos, es muy interesante la posibilidad de generación de informes con los 
resultados obtenidos. 

 

4.3.1. Informes HTML 

 
La manera de sencilla de obtener un informe en HTML es seleccionar la poción de menú View > Report. 

Lo que guardará el informe HTML generado en una archivo temporal y lo mostrará en la sección de Navegación 
de Badboy. 

 
Si se desea guardar o enviar el informe generado se puede usar la opción de menú File > Save as > 

HTML Report... La figura siguiente muestra el aspecto de un informe HTML: 
 

 
 
 

Guardar un informe HTML como parte del script 

 
Se puede realizar la generación de informes de manera automática. Para ello, se usará elemento Save 
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Item de la caja de herramientas. 
 

 
 
Se deberá seleccionar la opción Script del marco What to Save y elegir la opción HTML Report como 

queda reflejado en la imagen siguiente: 
 

 
 

 
 

5 Parametrización: Integración BadBoy - XLNets 

 
Se proporciona un script que automatiza el proceso de validación contra XLNets y que automáticamente 

redirige a la página de inicio de una determinada aplicación. 
 

Script_XLNets.bb
 

 
Puede resultar necesario marcar estas opciones para no tener errores en la ejecución de la prueba: 
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5.1 Apertura de script 

 
Iniciado Badboy, el siguiente paso consiste en abrir el fichero a parametrizar con los datos de una 

determinada aplicación. 
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Se mostrara a continuación la típica ventana de exploración en la cual debemos buscar y seleccionar el 

fichero con el script a abrir. El fichero que integra dicha funcionalidad se denomina Script_XLNets.bb. 
 

5.2 Personalización de parámetros 

 
Una vez abierto podemos observar como el script cuenta con una serie de variables ya declaradas y 

definidas. Dichas variables son las que deberemos modificar acorde a los datos reales de la aplicación que 
deseamos probar. 
 

A continuación se describe cada una de las variables creadas: 
  

 password: Se trata de la contraseña que se va a utilizar para acceder a XLNETS. 
 usuario: Se trata del nombre de usuario que se va a utilizar para acceder a XLNETS. 

 
El script tiene 2 casos de prueba, uno que hace login con usuario y password y otro que usa un certificado. El 
certificado puede instalarse a partir de 
http://elkarlan.ejie/webguneak/otc/Entregables/Repositorio%20Base/HERRAMIENTAS/Herramientas%20de%20calidad/Man
uales%20de%20usuario/Automatización%20Pruebas/Kit%20certificados%20ficticios%20Desarrollo%20IZENPE.zip 
 
Se recomienda instalar sólo un certificado, así no se solicitará seleccionarlo al ejecutar la prueba. 

 
 


